WEBアプリケーション研究室 開発ノート TOP

WEBアプリケーション研究室 開発ノート [symfony] package.xmlのdependenciesについて

スポンサーサイト

-------- --:--

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

    このエントリーをはてなブックマークに追加

pluginを本家にあげてみたところ1.2系でうまくインストールできませんでした。


symfony plugin:install gmDumpVarPlugin
No release available for plugin "gmDumpVarPlugin"

package.xmlを正しくインストールできるものとよく見比べたところsymfonyのpackageのdependenciesに問題があるのがわかりました。
最初は

<dependencies>
<required>
<php>
<min>5.1.0</min>
</php>
<pearinstaller>
<min>1.4.1</min>
</pearinstaller>
<package>
<name>symfony</name>
<channel>pear.symfony-project.com</channel>
<min>1.1.0</min>
<max>1.2.4</max>
</package>
</required>
</dependencies>

と書いたのですが

<dependencies>
<required>
<php>
<min>5.1.0</min>
</php>
<pearinstaller>
<min>1.4.1</min>
</pearinstaller>
<package>
<name>symfony</name>
<channel>pear.symfony-project.com</channel>
<min>1.1.0</min>
<max>1.3.0</max>
<exclude>1.3.0</exclude>
</package>
</required>
</dependencies>

に直したらインストールできるようになりました。
<max>1.3.0</max>
はmaxのバージョンを含まないようですね。たぶん1.2.5とかにしてもインストールできそうですがsf系のpluginが上記のように書いてあったので真似をしました。
スポンサーサイト

    このエントリーをはてなブックマークに追加
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。